Watershed Reporting and data search not operational
Incident Report for Watershed LRS - EU
Resolved
This incident has been resolved.
Posted Dec 09, 2022 - 10:14 CST
Update
We are continuing to investigate this issue.
Posted Dec 09, 2022 - 09:30 CST
Investigating
We are currently investigating this issue.
Posted Dec 09, 2022 - 09:30 CST
This incident affected: Analytics Database.